Via Falcon & Null Modem cable

From AtariForumWiki
Jump to: navigation, search

Getting a Falcon to the Internet through a null modem cable.

For a first post I will attempt to describe the process to get the Falcon online or to an already established network with the use of a null modem cable. It took me 5 days to get it (almost) properly working and I write this in the hope that it won't take you that long. So here we go!

Windows:

The first thing that you need to do is to change your null modem driver and create an incoming connection. This process is described here so I won't do it again. One thing to know though. When you enter the Internet properties make sure that you specify a range of addresses bigger than 2, e.g.

From: 192.168.0.2 to 192.168.0.4


And make sure that the from address is your PC's address in the already established network. My PC is connected to the Internet through a router so I don't know how these settings change if yours is connected directly to it. Experiment....:)

Atari side: On the Falcon I am using Mintnet. I created an options file that should have the following:

  1. Options file for Mintnet pppd

lock debug crtscts noauth defaultroute asyncmap 0

A good idea would be to also edit your /etc/resolv.conf and your /etc/hosts files. In the first file you must add the DNS servers of your ISP or as some suggest your routers address in the network. I added them all...

  1. /etc/resolv.conf

nameserver xxx.xxx.xxx.xxx nameserver xxx.xxx.xxx.xxx nameserver xxx.xxx.xxx.xxx nameserver xxx.xxx.xxx.xxx

where xxx.xxx.xxx.xxx are the respective IP addresses. In the hosts file you can name the various IP addresses in your network so you don't have to deal with them all the time.

The moment of truth:

Start a shell and type in: pppd -detach /dev/ttyS1 57600 &

If all went well a connection to the machine will be established and you are set to go to the Internet.

  • ttySx is the number of the serial port you've connected the null modem cable to. If it's modem 1 than it should be ttyS0.
  • 57600 is the speed of the connection - others report a stable connection at 115200 but I'll get back to it later...

Linux:

If you are using Linux as your pc's operating system than open a shell and type this:

pppd -detach crtscts asyncmap 0 noauth proxyarp xxx.xxx.xxx.xxx:yyy.yyy.yyy.yyy /dev/ttyS0 57600 &

xxx.xxx.xxx.xxx is the IP address of your PC in the network, and yyy.yyy.yyy.yyy the assigned IP address to your Atari. Again make sure that yyy.yyy.yyy.yyy - xxx.xxx.xxx.xxx >= 2

Run the ppp daemon on the Atari and if everything goes well you are connected and with access to the Internet...


Problems:

I cant seem to get a stable connection at any speed. After a while though the computers seem to remain connected no packets are transmitted and I have no idea of the cause. I suspect the null modem cable but it works very well with ghostlink so I am at a loss.

References: I' ve read so many texts about this, visited so many forums that I am going to forget many helpful sites. A big thank you to those I forget....

Patrice' s site [1] Mintnet for Lamers [2]

Linux Networking How to [3] Yolinux [4]

Plus thanks to Anders and ggn for their help



Back to Internet Access