Help running Atari 800 terminal emulator from MIT

All discussions about the Atari 8bit range of machines.

Moderators: Mug UK, Silver Surfer, Moderator Team

Post Reply
User avatar
larsbrinkhoff
Atariator
Atariator
Posts: 29
Joined: Fri Mar 18, 2016 3:03 pm
Contact:

Help running Atari 800 terminal emulator from MIT

Post by larsbrinkhoff »

Hello,

I have found a precursor or parallel offshoot from Jack Palevich's terminal emulator Chameleon. It was found on PDP-10 backup tapes from MIT's Logo lab (a part of the infamous AI lab).

The source code assembles without errors using a cross assembler running on ITS (the Incompatible Timesharing System). The output from the assembler is a binary block-structured file. I have converted this to an Atari DOS executable file. I tried to run it on the Atari800 emulator, but I just get a blank screen. I would appreciate some hints how to run this program.

The source code is available in this GitHub pull request:
https://github.com/PDP-10/its/pull/2034

I'm attaching the converted binary file, assembled with BINARY defined. From a comment: "Binary i.e. Testing phase where no copy is kept of the code, we just jump right to it." which assembles a JMP BEGIN at addres 0600.
You do not have the required permissions to view the files attached to this post.
User avatar
larsbrinkhoff
Atariator
Atariator
Posts: 29
Joined: Fri Mar 18, 2016 3:03 pm
Contact:

Re: Help running Atari 800 terminal emulator from MIT

Post by larsbrinkhoff »

Fixed with some help on the AtariAge forum.
Post Reply

Return to “The Atari 8bit corner”